-
Notifications
You must be signed in to change notification settings - Fork 6
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request #2 from Geontech/krogoth
Bump to RH 2.0.4, split recipes, and tested against Yocto Krogoth
- Loading branch information
Showing
126 changed files
with
1,515 additions
and
2,737 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,73 @@ | ||
# | ||
# This file is protected by Copyright. Please refer to the COPYRIGHT file distributed | ||
# with this source distribution. | ||
# | ||
# This file is part of Geon Technology's meta-redhawk-sdr. | ||
# | ||
# Geon Technology's meta-redhawk-sdr is free software: you can redistribute it and/or | ||
# modify it under the terms of the GNU Lesser General Public License as published by | ||
# the Free Software Foundation, either version 3 of the License, or (at your option) | ||
# any later version. | ||
# | ||
# Geon Technology's meta-redhawk-sdr is distributed in the hope that it will be useful, | ||
# but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or | ||
# FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more | ||
# details. | ||
# | ||
# You should have received a copy of the GNU Lesser General Public License | ||
# along with this program. If not, see http://www.gnu.org/licenses/. | ||
# | ||
|
||
DESCRIPTION = "OmniEvents" | ||
SECTION = "devel" | ||
PRIORITY = "optional" | ||
LICENSE = "GPL-2.0" | ||
LIC_FILES_CHKSUM = "file://LICENSE;md5=68ad62c64cc6c620126241fd429e68fe" | ||
DEPENDS += "omniorb boost" | ||
|
||
# Sources, by default allow for the use of SRCREV pointing to orphaned tags/commits | ||
SRCTAG ?= "" | ||
SRCTAGARG = "${@['nobranch=1', 'tag=${SRCTAG}'][d.getVar('SRCTAG', True) != '']}" | ||
|
||
SRC_URI = "git://github.com/redhawksdr/omniEvents.git;${SRCTAGARG};protocol=git \ | ||
file://omniEvents.patch \ | ||
file://config.mk.patch \ | ||
file://omniEvents \ | ||
" | ||
|
||
S = "${WORKDIR}/git" | ||
|
||
inherit autotools pkgconfig update-rc.d | ||
|
||
EXTRA_OECONF="\ | ||
--with-omniorb=${STAGING_DIR}/${MACHINE}/usr \ | ||
--with-boost=${STAGING_DIR}/${MACHINE}/usr \ | ||
" | ||
|
||
# Over-write default multi-threaded build temporarily. | ||
PARALLEL_MAKE = "" | ||
|
||
# omniNames is 10, omniEvents will be 11. | ||
INITSCRIPT_NAME = "omniEvents" | ||
INITSCRIPT_PARAMS = "defaults 11" | ||
|
||
do_configure_append () { | ||
# omniEvents isn't quite as auto-tooled as omniNames so its build | ||
# in OE is a bit more involved; we have to manually copy sources, make files, etc. | ||
# At this point, we're in the build folder. | ||
cp -r ../git/Makefile ../git/idl ../git/src ../git/contrib ../git/tools ../git/examples . | ||
} | ||
|
||
do_compile () { | ||
export IDL=${STAGING_DIR}/${BUILD_SYS}/usr/bin/omniidl | ||
export IDL_COS_DIR=${STAGING_DIR}/${BUILD_SYS}/usr/share/idl/omniORB | ||
oe_runmake | ||
} | ||
|
||
do_install () { | ||
# Set a variable that the Makefiles obey for install. | ||
autotools_do_install | ||
install -d ${D}/etc ${D}/etc/init.d | ||
install -m 0755 ${WORKDIR}/omniEvents ${D}/etc/init.d/omniEvents | ||
} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,69 +1,4 @@ | ||
# | ||
# This file is protected by Copyright. Please refer to the COPYRIGHT file distributed | ||
# with this source distribution. | ||
# | ||
# This file is part of Geon Technology's meta-redhawk-sdr. | ||
# | ||
# Geon Technology's meta-redhawk-sdr is free software: you can redistribute it and/or | ||
# modify it under the terms of the GNU Lesser General Public License as published by | ||
# the Free Software Foundation, either version 3 of the License, or (at your option) | ||
# any later version. | ||
# | ||
# Geon Technology's meta-redhawk-sdr is distributed in the hope that it will be useful, | ||
# but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or | ||
# FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more | ||
# details. | ||
# | ||
# You should have received a copy of the GNU Lesser General Public License | ||
# along with this program. If not, see http://www.gnu.org/licenses/. | ||
# | ||
|
||
DESCRIPTION = "OmniEvents" | ||
SECTION = "devel" | ||
PRIORITY = "optional" | ||
LICENSE = "GPL-2.0" | ||
LIC_FILES_CHKSUM = "file://LICENSE;md5=68ad62c64cc6c620126241fd429e68fe" | ||
DEPENDS += "omniorb boost" | ||
|
||
SRC_URI = "git://github.com/redhawksdr/omniEvents.git;branch=develop;tag=2.7.0;protocol=git \ | ||
file://omniEvents.patch \ | ||
file://config.mk.patch \ | ||
file://omniEvents \ | ||
" | ||
|
||
S = "${WORKDIR}/git" | ||
|
||
inherit autotools pkgconfig update-rc.d | ||
|
||
EXTRA_OECONF="\ | ||
--with-omniorb=${STAGING_DIR}/${MACHINE}/usr \ | ||
--with-boost=${STAGING_DIR}/${MACHINE}/usr \ | ||
" | ||
|
||
# Over-write default multi-threaded build temporarily. | ||
PARALLEL_MAKE = "" | ||
|
||
# omniNames is 10, omniEvents will be 11. | ||
INITSCRIPT_NAME = "omniEvents" | ||
INITSCRIPT_PARAMS = "defaults 11" | ||
|
||
do_configure_append () { | ||
# omniEvents isn't quite as auto-tooled as omniNames so its build | ||
# in OE is a bit more involved; we have to manually copy sources, make files, etc. | ||
# At this point, we're in the build folder. | ||
cp -r ../git/Makefile ../git/idl ../git/src ../git/contrib ../git/tools ../git/examples . | ||
} | ||
|
||
do_compile () { | ||
export IDL=${STAGING_DIR}/${BUILD_SYS}/usr/bin/omniidl | ||
export IDL_COS_DIR=${STAGING_DIR}/${BUILD_SYS}/usr/share/idl/omniORB | ||
oe_runmake | ||
} | ||
|
||
do_install () { | ||
# Set a variable that the Makefiles obey for install. | ||
autotools_do_install | ||
install -d ${D}/etc ${D}/etc/init.d | ||
install -m 0755 ${WORKDIR}/omniEvents ${D}/etc/init.d/omniEvents | ||
} | ||
SRCTAG = "2.7.0" | ||
PREFERRED_VERSION_omniorb = "4.1.6" | ||
include omnievents.inc | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
SRCTAG = "2.7.1" | ||
PREFERRED_VERSION_omniorb = "4.2.0" | ||
include omnievents.inc | ||
|
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- a/src/tool/omniidl/cxx/dir.mk 2014-03-25 11:22:12.000000000 -0400 | ||
+++ b/src/tool/omniidl/cxx/dir.mk 2017-01-06 13:49:56.793626502 -0500 | ||
@@ -73,14 +73,14 @@ | ||
|
||
ifdef UnixPlatform | ||
#CXXDEBUGFLAGS = -g | ||
-PYPREFIX := $(shell $(PYTHON) -c 'import sys; sys.stdout.write(sys.exec_prefix)') | ||
+PYPREFIX := $(PREFIX) | ||
PYVERSION := $(shell $(PYTHON) -c 'import sys; sys.stdout.write(sys.version[:3])') | ||
PYINCDIR := $(PYPREFIX)/include | ||
PYINCFILE := "<python$(PYVERSION)/Python.h>" | ||
DIR_CPPFLAGS += -I$(PYINCDIR)/python$(PYVERSION) \ | ||
-I$(PYINCDIR)/python$(PYVERSION)mu \ | ||
-I$(PYINCDIR) \ | ||
- -DPYTHON_INCLUDE="<Python.h>" | ||
+ -DPYTHON_INCLUDE=$(PYINCFILE) | ||
endif | ||
|
||
|
||
|
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,75 @@ | ||
diff -Nuar omniORB-4.2.0/include/omniORB4/CORBA_sysdep_auto.h omniORB-4.2.0-patched/include/omniORB4/CORBA_sysdep_auto.h | ||
--- omniORB-4.2.0/include/omniORB4/CORBA_sysdep_auto.h 2013-07-18 07:28:03.000000000 -0400 | ||
+++ omniORB-4.2.0-patched/include/omniORB4/CORBA_sysdep_auto.h 2017-01-09 08:34:47.292907892 -0500 | ||
@@ -70,12 +70,12 @@ | ||
|
||
#if !defined(OMNIORB_DISABLE_LONGDOUBLE) | ||
# if defined(SIZEOF_LONG_DOUBLE) && (SIZEOF_LONG_DOUBLE == 16) | ||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
# endif | ||
|
||
# if defined(SIZEOF_LONG_DOUBLE) && (SIZEOF_LONG_DOUBLE == 12) && defined(__i386__) | ||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
# endif | ||
#endif | ||
diff -Nuar omniORB-4.2.0/include/omniORB4/CORBA_sysdep_trad.h omniORB-4.2.0-patched/include/omniORB4/CORBA_sysdep_trad.h | ||
--- omniORB-4.2.0/include/omniORB4/CORBA_sysdep_trad.h 2014-01-17 10:27:56.000000000 -0500 | ||
+++ omniORB-4.2.0-patched/include/omniORB4/CORBA_sysdep_trad.h 2017-01-09 08:37:30.544545283 -0500 | ||
@@ -136,7 +136,7 @@ | ||
|
||
// GCC claims to support long long on all platforms | ||
# define HAS_LongLong | ||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
# define _CORBA_LONGLONG_DECL long long | ||
# define _CORBA_ULONGLONG_DECL unsigned long long | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
@@ -190,7 +190,7 @@ | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
# define _CORBA_LONGLONG_CONST(x) (x##LL) | ||
|
||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
|
||
|
||
#elif defined(_MSC_VER) | ||
@@ -223,7 +223,7 @@ | ||
|
||
# define HAVE_STRTOULL | ||
|
||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
# define HAS_LongLong | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
# define _CORBA_LONGLONG_DECL long long | ||
@@ -258,7 +258,7 @@ | ||
# define HAS_Cplusplus_const_cast | ||
# define OMNI_REQUIRES_FQ_BASE_CTOR | ||
# define HAS_LongLong | ||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
# define _CORBA_LONGLONG_DECL long long | ||
# define _CORBA_ULONGLONG_DECL unsigned long long | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
@@ -283,7 +283,7 @@ | ||
# define HAS_Cplusplus_Namespace | ||
# define HAS_Std_Namespace | ||
# define HAS_LongLong | ||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
# define _CORBA_LONGLONG_DECL long long | ||
# define _CORBA_ULONGLONG_DECL unsigned long long | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
@@ -303,7 +303,7 @@ | ||
# define _CORBA_ULONGLONG_DECL unsigned long long | ||
# define _CORBA_LONGLONG_CONST(x) (x##LL) | ||
# if defined(_FPWIDETYPES) | ||
-# define HAS_LongDouble | ||
+// # define HAS_LongDouble | ||
# define _CORBA_LONGDOUBLE_DECL long double | ||
# endif | ||
# ifndef HAVE_STD |
Oops, something went wrong.