Skip to content

Commit

Permalink
updpatch: python-executing 2.0.0-1
Browse files Browse the repository at this point in the history
Fix rotten.
  • Loading branch information
felixonmars committed Oct 5, 2023
1 parent 3ddb192 commit 6caf561
Showing 1 changed file with 16 additions and 20 deletions.
36 changes: 16 additions & 20 deletions python-executing/riscv64.patch
Original file line number Diff line number Diff line change
@@ -1,26 +1,22 @@
Index: PKGBUILD
===================================================================
--- PKGBUILD (revision 1347474)
+++ PKGBUILD (working copy)
@@ -12,10 +12,18 @@
makedepends=('python-build' 'python-installer' 'python-setuptools-scm'
'python-wheel')
checkdepends=('python-asttokens' 'python-littleutils' 'python-pytest')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('19da64c18d2d851112f09c287f8d3dbbdf725ab0e569077efb6cdcbd3497c107')
-b2sums=('662048e98a1eb3128dd57bbd61a8b7d7fb90dcf5adabc532c69f9ecce2a8ca73cf496ce7ba9b19c94d40083be1382b59dd673b36840e004a7cd0add888292ada')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
diff --git PKGBUILD PKGBUILD
index 45cd750..d894963 100644
--- PKGBUILD
+++ PKGBUILD
@@ -17,8 +17,15 @@ makedepends=(
'python-wheel'
)
checkdepends=('ipython' 'python-asttokens' 'python-littleutils' 'python-pytest')
-source=("git+$url.git#tag=v$pkgver")
-b2sums=('SKIP')
+source=("git+$url.git#tag=v$pkgver"
+ "fix-test-many-source-for-filename-calls-timeout.patch")
+sha256sums=('19da64c18d2d851112f09c287f8d3dbbdf725ab0e569077efb6cdcbd3497c107'
+ '5161cd421781dcbdf533513440ca03d3a78e5cfbb0877f72815d679d3f10e76f')
+b2sums=('662048e98a1eb3128dd57bbd61a8b7d7fb90dcf5adabc532c69f9ecce2a8ca73cf496ce7ba9b19c94d40083be1382b59dd673b36840e004a7cd0add888292ada'
+b2sums=('SKIP'
+ '152545e095b4ed4401a199a22196f97ee7f7cca220063c4734ea33d70e0640f234e95f0a52cbf3aa8c15a8cc940e03f97ed636193b33db4892d4b73e55071c52')
+
+prepare() {
+ cd "$_name-$pkgver"
+ cd "$_name"
+ patch -Np1 -i ../fix-test-many-source-for-filename-calls-timeout.patch
+}
+
build() {
cd "$_name-$pkgver"
python -m build --wheel --skip-dependency-check --no-isolation
cd "$_name"

0 comments on commit 6caf561

Please sign in to comment.