Skip to content

Commit

Permalink
msys2-runtime: update to 6469fc6ad6b20f6a1e7e84e1a4924f4bd77bf48d
Browse files Browse the repository at this point in the history
Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
  • Loading branch information
dscho committed Nov 13, 2024
1 parent 8ffcaf3 commit 82fe21c
Show file tree
Hide file tree
Showing 3 changed files with 84 additions and 6 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
From 6469fc6ad6b20f6a1e7e84e1a4924f4bd77bf48d Mon Sep 17 00:00:00 2001
From: Johannes Schindelin <johannes.schindelin@gmx.de>
Date: Tue, 12 Nov 2024 22:21:08 +0100
Subject: [PATCH 54/N] cygthread: suspend thread before terminating.

This addresses an extremely difficult to debug deadlock when running
under emulation on ARM64.

A relatively easy way to trigger this bug is to call `fork()`, then
within the child process immediately call another `fork()` and then
`exit()` the intermediate process.

It would seem that there is a "code emulation" lock on the wait thread
at this stage, and if the thread is terminated too early, that lock
still exists albeit without a thread, and nothing moves forward.

It seems that a `SuspendThread()` combined with a `GetThreadContext()`
(to force the thread to _actually_ be suspended, for more details see
https://devblogs.microsoft.com/oldnewthing/20150205-00/?p=44743) makes
sure the thread is "booted" from emulation before it is suspended.

Hopefully this means it won't be holding any locks or otherwise leave
emulation in a bad state when the thread is terminated.

Also, attempt to use `CancelSynchonousIo()` (as seen in `flock.cc`) to
avoid the need for `TerminateThread()` altogether. This doesn't always
work, however, so was not a complete fix for the deadlock issue.

Addresses: https://cygwin.com/pipermail/cygwin-developers/2024-May/012694.html
Signed-off-by: Jeremy Drake <cygwin@jdrake.com>
Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
---
winsup/cygwin/cygthread.cc | 14 ++++++++++++++
winsup/cygwin/sigproc.cc | 3 ++-
2 files changed, 16 insertions(+), 1 deletion(-)

diff --git a/winsup/cygwin/cygthread.cc b/winsup/cygwin/cygthread.cc
index 54918e7..4f16097 100644
--- a/winsup/cygwin/cygthread.cc
+++ b/winsup/cygwin/cygthread.cc
@@ -302,6 +302,20 @@ cygthread::terminate_thread ()
if (!inuse)
goto force_notterminated;

+ if (_my_tls._ctinfo != this)
+ {
+ CONTEXT context;
+ context.ContextFlags = CONTEXT_CONTROL;
+ /* SuspendThread makes sure a thread is "booted" from emulation before
+ it is suspended. As such, the emulator hopefully won't be in a bad
+ state (aka, holding any locks) when the thread is terminated. */
+ SuspendThread (h);
+ /* We need to call GetThreadContext, even though we don't care about the
+ context, because SuspendThread is asynchronous and GetThreadContext
+ will make sure the thread is *really* suspended before returning */
+ GetThreadContext (h, &context);
+ }
+
TerminateThread (h, 0);
WaitForSingleObject (h, INFINITE);
CloseHandle (h);
diff --git a/winsup/cygwin/sigproc.cc b/winsup/cygwin/sigproc.cc
index 5c5ff73..d180277 100644
--- a/winsup/cygwin/sigproc.cc
+++ b/winsup/cygwin/sigproc.cc
@@ -410,7 +410,8 @@ proc_terminate ()
if (!have_execed || !have_execed_cygwin)
chld_procs[i]->ppid = 1;
if (chld_procs[i].wait_thread)
- chld_procs[i].wait_thread->terminate_thread ();
+ if (!CancelSynchronousIo (chld_procs[i].wait_thread->thread_handle ()))
+ chld_procs[i].wait_thread->terminate_thread ();
/* Release memory associated with this process unless it is 'myself'.
'myself' is only in the chld_procs table when we've execed. We
reach here when the next process has finished initializing but we
13 changes: 8 additions & 5 deletions msys2-runtime/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
pkgbase=msys2-runtime
pkgname=('msys2-runtime' 'msys2-runtime-devel')
pkgver=3.5.4
pkgrel=3
pkgrel=4
pkgdesc="Cygwin POSIX emulation engine"
arch=('x86_64')
url="https://www.cygwin.com/"
Expand Down Expand Up @@ -79,9 +79,10 @@ source=('msys2-runtime'::git+https://github.com/cygwin/cygwin#tag=cygwin-${pkgve
0050-Cygwin-pipe-Fix-a-regression-that-raw_write-slows-do.patch
0051-Cygwin-pipe-Restore-blocking-mode-of-read-pipe-on-cl.patch
0052-Fix-SSH-hangs.patch
0053-Cygwin-find_fast_cwd-don-t-run-assembler-checking-co.patch)
0053-Cygwin-find_fast_cwd-don-t-run-assembler-checking-co.patch
0054-cygthread-suspend-thread-before-terminating.patch)
sha256sums=('3812485e2a6ab8360e5b9d566a47b982852ff2b140cea4e332ded19c11c77663'
'490f290676fc38e51b5084ed7061c1abb70a462bf3067941b01a52e60662aecc'
'a1ccf0cab1544eb266caa467817c2d525fe48bc47247c4302b81f46aaada9677'
'9f9e1b6b05cbc9a715fe9443740b25171e9c1a276a058e6ba7e4f6eada6872c8'
'e5b2095e543a5d702cfce6da26cd17a78f40e17620315b1bcc434b94a007ae9b'
'f13b15dc14aa6ee1dd628a2487564bb484e74ff2f3e4059b9d9d64446a327db1'
Expand Down Expand Up @@ -134,7 +135,8 @@ sha256sums=('3812485e2a6ab8360e5b9d566a47b982852ff2b140cea4e332ded19c11c77663'
'394229cfa5293e4572dfd7155605343ca7426395429fa47eb38aced11d4f924b'
'590dc0ce9e72a1adf1424c7a4f55bd57d8955eef036776895b3d779d4932d4ce'
'75e22e453011ea15c6cf6b6904c33256530d6f4ba273f03bc6a37d9245064c8c'
'7fe562197a1f3b67b1e794808186c10ff0186b0fcf8d09a8021499b952d04d2c')
'7fe562197a1f3b67b1e794808186c10ff0186b0fcf8d09a8021499b952d04d2c'
'5ee3136a522cff35da3dd7cf7280f87bc855083832cc5cc3a5d24ea996c9d04c')

# Helper macros to help make tasks easier #
apply_patch_with_msg() {
Expand Down Expand Up @@ -241,7 +243,8 @@ prepare() {
0050-Cygwin-pipe-Fix-a-regression-that-raw_write-slows-do.patch \
0051-Cygwin-pipe-Restore-blocking-mode-of-read-pipe-on-cl.patch \
0052-Fix-SSH-hangs.patch \
0053-Cygwin-find_fast_cwd-don-t-run-assembler-checking-co.patch
0053-Cygwin-find_fast_cwd-don-t-run-assembler-checking-co.patch \
0054-cygthread-suspend-thread-before-terminating.patch
}

build() {
Expand Down
2 changes: 1 addition & 1 deletion msys2-runtime/msys2-runtime.commit
Original file line number Diff line number Diff line change
@@ -1 +1 @@
6183b8336e29b058b63dcf97ff8214b0355f165a
6469fc6ad6b20f6a1e7e84e1a4924f4bd77bf48d

0 comments on commit 82fe21c

Please sign in to comment.