Skip to content

Commit

Permalink
Merge remote-tracking branch 'dscho/openssh'
Browse files Browse the repository at this point in the history
This updates primarily the definition of OpenSSH to the latest version,
but at the same time updates everything else to current upstream, too.

Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
  • Loading branch information
dscho committed Aug 24, 2016
2 parents d725052 + da63f58 commit 95bd091
Show file tree
Hide file tree
Showing 167 changed files with 12,340 additions and 2,173 deletions.
15 changes: 8 additions & 7 deletions .drone.yml
Original file line number Diff line number Diff line change
@@ -1,9 +1,10 @@
build:
image: teaci/msys32
image: teaci/msys$$arch
pull: true
shell: msys32
shell: msys$$arch
commands:
- export RUNTEST=$$runtest
# TODO: remove this option when not anymore needed
- if [ $$arch = 32 ]; then export DISABLE_QUALITY_CHECK=true; fi
- ./ci-build.sh

notify:
Expand All @@ -16,7 +17,7 @@ notify:
port: 6667

matrix:
runtest:
- false
# Temprorary disable matrix build to workaround irc plugin bug on wine-ci.org, see https://github.com/drone/drone/issues/1459
# - true # allow failures
arch:
- 64
- 32
#FIXME: When a matrix build is done, only the build status of the last job in a matrix is sent to notification plugins, this confuses our irc plugin, see https://github.com/drone/drone/issues/1459. Github pull request Web UI status and Tea CI Web UI status works fine with matrix build.
2 changes: 1 addition & 1 deletion README.md
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@ MSYS2-packages

Package scripts for MSYS2.

To build these, run msys2_shell.bat then from the bash prompt.
To build these, run msys2_shell.cmd then from the bash prompt.

cd ${package-name}
makepkg
Expand Down
5 changes: 2 additions & 3 deletions appveyor.yml
Original file line number Diff line number Diff line change
Expand Up @@ -6,8 +6,7 @@ environment:
BUILD_URL: https://ci.appveyor.com/project/$(APPVEYOR_ACCOUNT_NAME)/$(APPVEYOR_PROJECT_NAME)/build/$(APPVEYOR_BUILD_VERSION)

build_script:
# TODO: implement update-core --noconfirm and replace the below command line
- C:\msys64\usr\bin\pacman --sync --refresh --refresh --needed --noconfirm msys2-runtime msys2-runtime-devel bash pacman pacman-mirrors
- C:\msys64\usr\bin\pacman --noconfirm --sync --refresh --refresh --sysupgrade --sysupgrade
- C:\msys64\usr\bin\bash --login -c "$(cygpath ${APPVEYOR_BUILD_FOLDER})/ci-build.sh"

artifacts:
Expand All @@ -23,4 +22,4 @@ deploy:
publish: true
override: true
api_key:
secure: BINTRAY_TOKEN_ENCRYPTED_BY_APPVEYOR
secure: B2XBLbsX8EQOpWyyaHskipMoF2+Tbt6hc/afbVm82f01CBKruspjwhee4K4C7/xf
2 changes: 1 addition & 1 deletion bash/0001-bash-4.3-cygwin.patch
Original file line number Diff line number Diff line change
Expand Up @@ -209,7 +209,7 @@
@@ -161,6 +166,9 @@ static struct {
{ "compat40", &shopt_compat40, set_compatibility_level },
{ "compat41", &shopt_compat41, set_compatibility_level },
{ "compat42", &shopt_compat41, set_compatibility_level },
{ "compat42", &shopt_compat42, set_compatibility_level },
+#if __CYGWIN__
+ { "completion_strip_exe", &completion_strip_exe, NULL },
+#endif
Expand Down
15 changes: 12 additions & 3 deletions bash/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,9 +4,9 @@
pkgbase=bash
pkgname=('bash' 'bash-devel')
_basever=4.3
_patchlevel=042 #prepare for some patches
_patchlevel=046 #prepare for some patches
pkgver=${_basever}.${_patchlevel}
pkgrel=4
pkgrel=1
pkgdesc="The GNU Bourne Again shell"
arch=('i686' 'x86_64')
license=('GPL')
Expand Down Expand Up @@ -132,7 +132,7 @@ package_bash-devel() {

sha256sums=('afc687a28e0e24dc21b988fa159ff9dbcf6b7caa92ade8645cc6d5605cd024d4'
'SKIP'
'4e3bd589c3b3b39ced9ce824f9da39667ee8d6c8cc86de080b2714cb0db36d9a'
'4266bbb4c406e1b42b160e46897b9745621ac7cf2aad059ff270ba8312113edc'
'da08e4661fdcb179f7749dd1c8ce728d0ed8d4ca07e50da757046c06c6464dee'
'd833f89569b3d4ea4c78d998db087e60a426b8360a34707e80d71f3ce6ecc415'
'9829166ecd5d48651fb4a139f7e05053c775aa1a760ff4cf9561bbe6bae3d308'
Expand Down Expand Up @@ -222,4 +222,13 @@ sha256sums=('afc687a28e0e24dc21b988fa159ff9dbcf6b7caa92ade8645cc6d5605cd024d4'
'SKIP'
'4ec432966e4198524a7e0cd685fe222e96043769c9613e66742ac475db132c1a'
'SKIP'
'b75a53141ab3d8fff3fa74b5f3dc76468b01eae299f50bbc2bc71ae395d690af'
'SKIP'
'47a8a3c005b46e25821f4d8f5ccb04c1d653b1c829cb40568d553dc44f7a6180'
'SKIP'
'9338820630bf67373b44d8ea68409f65162ea7a47b9b29ace06a0aed12567f99'
'SKIP'
'ba6ec3978e9eaa1eb3fabdaf3cc6fdf8c4606ac1c599faaeb4e2d69864150023'
'SKIP'
'b3b456a6b690cd293353f17e22d92a202b3c8bce587ae5f2667c20c9ab6f688f'
'SKIP')
4 changes: 2 additions & 2 deletions bash/bash.install
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@ info_dir=usr/share/info
info_files=bash.info

post_upgrade() {
[ -x usr/bin/install-info ]
[ -x usr/bin/install-info ] || return 0
for f in ${info_files}; do
usr/bin/install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
done
}

pre_remove() {
[ -x usr/bin/install-info ]
[ -x usr/bin/install-info ] || return 0
for f in ${info_files}; do
usr/bin/install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
done
Expand Down
59 changes: 59 additions & 0 deletions bash/bash43-043
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
BASH PATCH REPORT
=================

Bash-Release: 4.3
Patch-ID: bash43-043

Bug-Reported-by: lolilolicon <lolilolicon@gmail.com>
Bug-Reference-ID: <CAMtVo_MF16KWanCB4C8WxA88Qt26zWsvV6V7+_U2fM0E6tCDxw@mail.gmail.com>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2014-08/msg00040.html

Bug-Description:

When the lastpipe option is enabled, the last component can contain nested
pipelines and cause a segmentation fault under certain circumestances.

Patch (apply with `patch -p0'):

*** ../bash-4.3-patched/execute_cmd.c 2014-07-30 10:26:52.000000000 -0400
--- execute_cmd.c 2014-08-15 08:55:24.000000000 -0400
***************
*** 2406,2412 ****
{
#if defined (JOB_CONTROL)
! append_process (savestring (the_printed_command), dollar_dollar_pid, exec_result, lastpipe_jid);
! #endif
lstdin = wait_for (lastpid);
#if defined (JOB_CONTROL)
/* If wait_for removes the job from the jobs table, use result of last
--- 2433,2447 ----
{
#if defined (JOB_CONTROL)
! if (INVALID_JOB (lastpipe_jid) == 0)
! {
! append_process (savestring (the_printed_command_except_trap), dollar_dollar_pid, exec_result, lastpipe_jid);
! lstdin = wait_for (lastpid);
! }
! else
! lstdin = wait_for_single_pid (lastpid); /* checks bgpids list */
! #else
lstdin = wait_for (lastpid);
+ #endif
+
#if defined (JOB_CONTROL)
/* If wait_for removes the job from the jobs table, use result of last
*** ../bash-4.3/patchlevel.h 2012-12-29 10:47:57.000000000 -0500
--- patchlevel.h 2014-03-20 20:01:28.000000000 -0400
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 42

#endif /* _PATCHLEVEL_H_ */
--- 26,30 ----
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 43

#endif /* _PATCHLEVEL_H_ */
Binary file added bash/bash43-043.sig
Binary file not shown.
48 changes: 48 additions & 0 deletions bash/bash43-044
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
BASH PATCH REPORT
=================

Bash-Release: 4.3
Patch-ID: bash43-044

Bug-Reported-by: Ondrej Oprala <ooprala@redhat.com>
Bug-Reference-ID: <539ED55B.2080103@redhat.com>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2014-06/msg00046.html

Bug-Description:

A typo prevents the `compat42' shopt option from working as intended.

Patch (apply with `patch -p0'):

diff -rC 2 bash-4.3.42/builtins/shopt.def bash-4.3.43/builtins/shopt.def
*** bash-4.3.42/builtins/shopt.def 2013-02-27 09:43:20.000000000 -0500
--- builtins/shopt.def 2015-10-16 11:25:28.000000000 -0400
***************
*** 161,165 ****
{ "compat40", &shopt_compat40, set_compatibility_level },
{ "compat41", &shopt_compat41, set_compatibility_level },
! { "compat42", &shopt_compat41, set_compatibility_level },
#if defined (READLINE)
{ "complete_fullquote", &complete_fullquote, (shopt_set_func_t *)NULL},
--- 161,165 ----
{ "compat40", &shopt_compat40, set_compatibility_level },
{ "compat41", &shopt_compat41, set_compatibility_level },
! { "compat42", &shopt_compat42, set_compatibility_level },
#if defined (READLINE)
{ "complete_fullquote", &complete_fullquote, (shopt_set_func_t *)NULL},

*** ../bash-4.3/patchlevel.h 2012-12-29 10:47:57.000000000 -0500
--- patchlevel.h 2014-03-20 20:01:28.000000000 -0400
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 43

#endif /* _PATCHLEVEL_H_ */
--- 26,30 ----
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 44

#endif /* _PATCHLEVEL_H_ */
Binary file added bash/bash43-044.sig
Binary file not shown.
52 changes: 52 additions & 0 deletions bash/bash43-045
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
BASH PATCH REPORT
=================

Bash-Release: 4.3
Patch-ID: bash43-045

Bug-Reported-by: Basin Ilya <basinilya@gmail.com>
Bug-Reference-ID: <5624C0AC.8070802@gmail.com>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2015-10/msg00141.html

Bug-Description:

If a file open attempted as part of a redirection fails because it is interrupted
by a signal, the shell needs to process any pending traps to allow the redirection
to be canceled.

Patch (apply with `patch -p0'):

*** bash-20150109/redir.c 2014-12-03 10:47:38.000000000 -0500
--- redir.c 2015-01-16 10:15:47.000000000 -0500
***************
*** 672,676 ****
e = errno;
if (fd < 0 && e == EINTR)
! QUIT;
errno = e;
}
--- 672,679 ----
e = errno;
if (fd < 0 && e == EINTR)
! {
! QUIT;
! run_pending_traps ();
! }
errno = e;
}

*** ../bash-4.3/patchlevel.h 2012-12-29 10:47:57.000000000 -0500
--- patchlevel.h 2014-03-20 20:01:28.000000000 -0400
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 44

#endif /* _PATCHLEVEL_H_ */
--- 26,30 ----
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 45

#endif /* _PATCHLEVEL_H_ */
Binary file added bash/bash43-045.sig
Binary file not shown.
55 changes: 55 additions & 0 deletions bash/bash43-046
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
BASH PATCH REPORT
=================

Bash-Release: 4.3
Patch-ID: bash43-046

Bug-Reported-by: Sergey Tselikh <stselikh@gmail.com>
Bug-Reference-ID: <20150816110235.91f3e12e3f20d20cdaad963e@gmail.com>
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2015-08/msg00080.html

Bug-Description:

An incorrect conversion from an indexed to associative array can result in a
core dump.

Patch (apply with `patch -p0'):

*** /fs2/chet/bash/bash-20150813/subst.c 2015-08-13 11:32:54.000000000 -0400
--- subst.c 2015-08-18 10:13:59.000000000 -0400
***************
*** 9562,9566 ****
opts[opti] = '\0';
if (opti > 0)
! make_internal_declare (tlist->word->word, opts);

t = do_word_assignment (tlist->word, 0);
--- 9562,9573 ----
opts[opti] = '\0';
if (opti > 0)
! {
! t = make_internal_declare (tlist->word->word, opts);
! if (t != EXECUTION_SUCCESS)
! {
! last_command_exit_value = t;
! exp_jump_to_top_level (DISCARD);
! }
! }

t = do_word_assignment (tlist->word, 0);

*** ../bash-4.3/patchlevel.h 2012-12-29 10:47:57.000000000 -0500
--- patchlevel.h 2014-03-20 20:01:28.000000000 -0400
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 45

#endif /* _PATCHLEVEL_H_ */
--- 26,30 ----
looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 46

#endif /* _PATCHLEVEL_H_ */
Binary file added bash/bash43-046.sig
Binary file not shown.
16 changes: 6 additions & 10 deletions ccache/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Maintainer: Mateusz Mikuła <mati865@gmail.com>
# Contributor: Renato Silva <br.renatosilva@gmail.com>

pkgname=ccache
pkgver=3.2.4
pkgrel=1
pkgver=3.2.5
pkgrel=2
pkgdesc="A compiler cache (mingw-w64)"
arch=('i686' 'x86_64')
url="https://ccache.samba.org/"
Expand All @@ -11,9 +12,11 @@ replaces=("${pkgname}-git")
makedepends=("gcc" "pkg-config")
depends=("gcc-libs" "zlib")
options=('staticlibs' 'strip')
install="${pkgname}.install"
source=(https://samba.org/ftp/ccache/${pkgname}-${pkgver}.tar.bz2{,.asc}
"MSYS2-dont-use-symlinks.patch")
sha256sums=('ffeb967edb549e67da0bd5f44f729a2022de9fdde65dfd80d2a7204d7f75332e'
validpgpkeys=("5A939A71A46792CF57866A51996DDA075594ADB8") #Joel Rosdahl <joel@rosdahl.net>
sha256sums=('7a553809e90faf9de3a23ee9c5b5f786cfd4836bf502744bedb824a24bee1097'
'SKIP'
'a0d2ea2ef1c9e59d4e5fdd659d291a4c7f4afc48ad50b1bc00f77349337d3167')

Expand All @@ -38,11 +41,4 @@ build() {
package() {
cd "${srcdir}/build-${CHOST}"
make DESTDIR="${pkgdir}" install

install -d ${pkgdir}/usr/lib/ccache/bin
cd ${pkgdir}/usr/lib/ccache/bin
scripts=(c++ cc cpp gcc g++ ${CARCH}-pc-msys-g++ ${CARCH}-pc-msys-c++ ${CARCH}-pc-msys-gcc)
for fn in ${scripts[*]}; do
echo -e '#!/bin/bash\n\nccache /usr/bin/'$fn' "$@"' > $fn
done
}
10 changes: 10 additions & 0 deletions ccache/ccache.install
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
post_install() {
mkdir -p /usr/lib/ccache/bin
for compiler in c++ cc cpp gcc g++ {i686,x86_64}-{pc-msys,w64-mingw32}-{g++,c++,gcc}; do
MSYS='winsymlinks:lnk' ln -sf /usr/bin/ccache /usr/lib/ccache/bin/${compiler}
done
}

pre_remove() { rm -rf /usr/lib/ccache; }
pre_upgrade() { pre_remove; }
post_upgrade() { post_install; }
5 changes: 3 additions & 2 deletions ci-build.sh
Original file line number Diff line number Diff line change
Expand Up @@ -22,11 +22,12 @@ define_build_order || failure 'Could not determine build order'

# Build
message 'Building packages' "${packages[@]}"
execute 'Upgrading the system' pacman --noconfirm --noprogressbar --sync --refresh --refresh --sysupgrade
execute 'Updating system' update_system
execute 'Approving recipe quality' check_recipe_quality
for package in "${packages[@]}"; do
execute 'Building binary' makepkg --noconfirm --noprogressbar --skippgpcheck --nocheck --syncdeps --rmdeps --cleanbuild
execute 'Building source' makepkg --noconfirm --noprogressbar --skippgpcheck --allsource
yes|execute 'Installing' pacman --noprogressbar --upgrade *.pkg.tar.xz
execute 'Installing' yes:pacman --noprogressbar --upgrade *.pkg.tar.xz
deploy_enabled && mv "${package}"/*.pkg.tar.xz artifacts
deploy_enabled && mv "${package}"/*.src.tar.gz artifacts
unset package
Expand Down
Loading

0 comments on commit 95bd091

Please sign in to comment.