Skip to content

Releases: mgcrea/react-native-dnd

v2.5.1

12 Dec 16:18
7d7c523
Compare
Choose a tag to compare
  • fix(useDraggableSort): properly track childrenIds (83b4a2d)

v2.5.0

12 Dec 16:03
c7e68f4
Compare
Choose a tag to compare
  • feat(update): minor changes (19319e4)
  • chore(sort): revert to measureLayout, only sort on children ids (e6116ad)
  • feat(update): minor changes (564a48d)
  • feat(provider): switch to absolute coordinates to allow more flexible layouts (f31a7d2)

v2.4.2

25 Nov 10:44
ea0274c
Compare
Choose a tag to compare
  • fix(api): do not use .get() yet (closes #32) (99556d0)
  • feat(update): minor changes (30261ab)
  • chore(ts): fix typechecking (f26d7ba)
  • feat(DndProvider): add droppableActiveId as meta property in onUpdate event (1ccb74e)

v2.4.1

23 Nov 08:16
fda7c2c
Compare
Choose a tag to compare
  • feat(DraggableStack): expose refreshOffsets method (34c4f15)
  • feat(update): minor changes (4581bfd)

v2.4.0

22 Nov 22:28
8025d33
Compare
Choose a tag to compare
  • feat(DraggableStack): working dynamic DraggableStack (closes #23) (96b4a45)
  • feat(DraggableSort): properly track added/removed items (closes #23) (9602f44)
  • feat(update): minor changes (06744f7)

v2.3.1

22 Nov 08:39
225d520
Compare
Choose a tag to compare
  • feat(docs): update docs (46a06d6)
  • feat(DndProvider): add shouldDropWorklet (closes #28) (7f72122)
  • chore(jest): use jest alpha to fix spec (87a5045)
  • chore(actions): fix test action (7bce885)
  • chore(actions): fix github actions (91602c8)
  • feat(DndProvider): rename onFeedback to onActivation (bc75a3f)
  • fix(eslint): correct eslint issues (7776249)
  • chore(utils): rename collision utils (c71f945)

v2.3.0

18 Nov 15:47
77eb033
Compare
Choose a tag to compare
  • chore(npm): bump deps, upgrade tooling stack (45e46c7)
  • chore(readme): remove haptic docs (0af41df)
  • docs(haptic): remove haptic related docs (7b3e2d7)
  • chore(deps): drop react-native-haptic-feedback dep, replace with onFeedback fn (closes #30) (c221960)
  • fix(dndProvider): prevent app crash on unmount (#26) (a3c63f2)
  • Merge pull request #20 from ImSingee/pr1 (26f042e)
  • chore(features): expose sort hooks api (27f75c9)
  • feat(update): minor changes (e7d937c)
  • feat(update): minor changes (d18361c)

v2.2.0

21 Dec 10:42
ed74072
Compare
Choose a tag to compare
  • feat(update): minor changes (9b040a4)
  • feat(update): minor changes (e80f9d2)
  • feat(docs): add DraggableGrid, DraggableStack docs (1a0e0cb)
  • docs(astro): bump astro to 4.0 (4fa0933)
  • chore(features): expose api (3d9902c)
  • feat(examples): update examples (851edd9)
  • feat(update): minor changes (e6c465f)
  • feat(update): minor changes (7f82a98)
  • feat(sort): add improved/updated sort implementation (d1bf845)
  • chore(project): major refactoring, remove existing grid feature (14159a8)
  • feat(draggable): working zIndex accross all states (d9440e6)

v2.1.1

04 Dec 20:14
c2dc5f5
Compare
Choose a tag to compare
  • feat(update): minor changes (282af35)

v2.1.0

04 Dec 20:09
835ed0f
Compare
Choose a tag to compare
  • feat(grid): add grid-related feature components (3736d22)