Skip to content

Commit

Permalink
[new-package] python-spyder-vim 0.1.0
Browse files Browse the repository at this point in the history
  • Loading branch information
podsvirov committed Dec 4, 2024
1 parent ad335dc commit aa54f65
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions mingw-w64-python-spyder-vim/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Maintainer: Konstantin Podsvirov <konstantin@podsvirov.pro>

_realname=spyder-vim
pkgbase=mingw-w64-python-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-python-${_realname}")
pkgver=0.1.0
pkgrel=1
pkgdesc='A plugin for Spyder to enable Vim keybindings (mingw-w64)'
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64')
url='https://github.com/spyder-ide/spyder-vim'
license=('spdx:MIT')
depends=("${MINGW_PACKAGE_PREFIX}-python"
"${MINGW_PACKAGE_PREFIX}-python-spyder")
makedepends=("${MINGW_PACKAGE_PREFIX}-python-build" "${MINGW_PACKAGE_PREFIX}-python-installer")
options=('!strip')
source=("https://pypi.org/packages/source/${_realname::1}/${_realname}/${_realname}-${pkgver}.tar.gz")
sha256sums=('97c2ef31ae9bb24af1853d3741081cc27867f4c170e031a07daa213cc79577ca')

build() {
cp -r "${_realname}-${pkgver}" "python-build-${MSYSTEM}" && cd "python-build-${MSYSTEM}"

python -m build --wheel --skip-dependency-check --no-isolation
}

package() {
cd "python-build-${MSYSTEM}"

MSYS2_ARG_CONV_EXCL="--prefix=" \
python -m installer --prefix=${MINGW_PREFIX} \
--destdir="${pkgdir}" dist/*.whl

install -Dm644 LICENSE.txt "${pkgdir}${MINGW_PREFIX}/share/licenses/python-${_realname}/LICENSE.txt"
}

0 comments on commit aa54f65

Please sign in to comment.