Skip to content

Commit

Permalink
pacman: drop clang32
Browse files Browse the repository at this point in the history
  • Loading branch information
MehdiChinoune committed Dec 19, 2024
1 parent da4f87d commit 0431c0d
Show file tree
Hide file tree
Showing 5 changed files with 11 additions and 26 deletions.
1 change: 1 addition & 0 deletions pacman/.gitignore
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
pacman
18 changes: 9 additions & 9 deletions pacman/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@

pkgname=pacman
pkgver=6.1.0
pkgrel=9
pkgrel=10
pkgdesc="A library-based package manager with dependency support (MSYS2 port)"
arch=('i686' 'x86_64')
url="https://www.archlinux.org/pacman/"
Expand Down Expand Up @@ -41,7 +41,7 @@ backup=("etc/pacman.conf"
"etc/makepkg.conf"
"etc/makepkg_mingw.conf")
_commit="e3dc296ba35d5039775c6e53decc7296b3bce396"
source=(pacman-${pkgver}::git+https://gitlab.archlinux.org/pacman/pacman.git#commit=${_commit}
source=(pacman::git+https://gitlab.archlinux.org/pacman/pacman.git#commit=${_commit}
"pacman.conf"
"makepkg.conf"
"makepkg_mingw.conf"
Expand Down Expand Up @@ -81,10 +81,10 @@ source=(pacman-${pkgver}::git+https://gitlab.archlinux.org/pacman/pacman.git#com
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
sha256sums=('803cba087e713a59866797747c3c63abbc0e4354c45cc2c0467d11e78364d66f'
'53c0c2d42bc10f265aa41bc412a6ebc2d98177d9356b0fa9a2a130caec46ac2d'
'0f25288c70ade80c7fac57d3149209b64a7ba23f00232b7e42103f6330b0c1c0'
'98bc3b83665ce0a102cd74b2a8e69c17eb6b55e0f89f17e57dc37d0f4577093a'
'754596f5bdf6ae6b03c04714ea60f7dcc95f89b71a28eae2e39a41cfff21c914'
'98198e1f0f252eae0560d271bee4b9149e127399dd0d3fd5d8d24579d9e0550f'
'a587b4bdad33d51d3e9505ca65faba12beaa818b496051c032f4916587aef107'
'df8c94263cc372938851ebbccaca8f73097e6e9a569ef2dbaf10217ad2d8a5ad'
'167e9ffe59e55fb07d47e0c9a4bddd9d967c50ec2c8711a0a0bbe4b184fc8b0f'
'1021dc5950ff9f9efac795688c4b53a1d3cda42b0f270ee755a038bbcf9eccab'
'af0c734c6efa167bdd9505f0cf8d5d85a8d535a5062a69b6e38473bb43b37aff'
Expand Down Expand Up @@ -127,7 +127,7 @@ apply_git_with_msg() {
}

prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
cd ${srcdir}/${pkgname}

# fixup symlinks
git config core.symlinks true
Expand Down Expand Up @@ -168,7 +168,7 @@ prepare() {
}

build() {
cd ${srcdir}/${pkgname}-${pkgver}
cd ${srcdir}/${pkgname}

LDFLAGS+=" -static-libgcc" \
meson setup build-${CARCH} \
Expand All @@ -190,12 +190,12 @@ build() {
}

check() {
cd ${srcdir}/${pkgname}-${pkgver}
cd ${srcdir}/${pkgname}
meson test -C build-${CARCH}
}

package() {
cd ${srcdir}/${pkgname}-${pkgver}
cd ${srcdir}/${pkgname}
DESTDIR=${pkgdir} meson install -C build-${CARCH}

# install Arch specific stuff
Expand Down
2 changes: 1 addition & 1 deletion pacman/makepkg-mingw
Original file line number Diff line number Diff line change
Expand Up @@ -84,7 +84,7 @@ if [[ -z "${MINGW_ARCH}" ]] && [[ -n "${MINGW_INSTALLS}" ]]; then
fi

# Validate or set MINGW_ARCH
MINGW_ARCH_ALLOWED=('mingw32' 'mingw64' 'clang32' 'clang64' 'clangarm64' 'ucrt64')
MINGW_ARCH_ALLOWED=('mingw32' 'mingw64' 'clang64' 'clangarm64' 'ucrt64')
MINGW_ARCH="${MINGW_ARCH,,}"
if [[ -z "$MINGW_ARCH" ]]; then
# In case MINGW_ARCH isn't set we default to MSYSTEM, or error out
Expand Down
13 changes: 0 additions & 13 deletions pacman/makepkg_mingw.conf
Original file line number Diff line number Diff line change
Expand Up @@ -72,19 +72,6 @@ elif [[ "$MSYSTEM" == "CLANG64" ]]; then
CXXFLAGS="$CFLAGS"
LDFLAGS=""
RUSTFLAGS="-Cforce-frame-pointers=yes"
elif [[ "$MSYSTEM" == "CLANG32" ]]; then
CARCH="i686"
CHOST="i686-w64-mingw32"
MINGW_CHOST="i686-w64-mingw32"
MINGW_PREFIX="/clang32"
MINGW_PACKAGE_PREFIX="mingw-w64-clang-i686"
CC="clang"
CXX="clang++"
CPPFLAGS=
CFLAGS="-march=pentium4 -mtune=generic -O2 -pipe -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong -Wp,-D__USE_MINGW_ANSI_STDIO=1"
CXXFLAGS="$CFLAGS"
LDFLAGS="-Wl,--no-seh -Wl,--large-address-aware"
RUSTFLAGS="-Cforce-frame-pointers=yes"
elif [[ "$MSYSTEM" == "CLANGARM64" ]]; then
CARCH="aarch64"
CHOST="aarch64-w64-mingw32"
Expand Down
3 changes: 0 additions & 3 deletions pacman/pacman.conf
Original file line number Diff line number Diff line change
Expand Up @@ -82,9 +82,6 @@ Include = /etc/pacman.d/mirrorlist.mingw
[ucrt64]
Include = /etc/pacman.d/mirrorlist.mingw

[clang32]
Include = /etc/pacman.d/mirrorlist.mingw

[clang64]
Include = /etc/pacman.d/mirrorlist.mingw

Expand Down

0 comments on commit 0431c0d

Please sign in to comment.