Skip to content

01 Installing Raspbian image

Aephir edited this page Jan 15, 2018 · 1 revision

To format and write Raspbain Stretch Lite from terminal on OS X

Open the Terminal app and write:

diskutil list

See you SD card, e.g. /dev/disk2. We will use /dev/disk2 as an example below, change according to the output of your diskutil list.

Umount and format SD card to fat32.

umount /dev/disk2
sudo diskutil eraseDisk FAT32 HASS MBRFormat /dev/disk2
diskutil unmountDisk /dev/disk2

This will name the SD card HASS. This doesn't really matter, since we will write a new image.

write the image. You can get the latest Raspbian Lite image as a zip file here: https://downloads.raspberrypi.org/raspbian_lite_latest. At the time of writing, this was Raspbian Stretch.

Unzip this and then write to your SD card by:

sudo dd bs=1m if=/Users/aephir/2017-11-29-raspbian-stretch-lite.img of=/dev/rdisk2

where /Users/aephir/2017-11-29-raspbian-stretch-lite.img is the location of your unzipped image file. Change according to you location and file.

Optional: Add an empty file to the boot partition called ssh. This enables SSH by default, so you can avoid connecting a monitor/TV and keyboard to your Raspberry Pi.

Unmount the SD card and insert into your Raspberry Pi and power it (preferably, add LAN cable for internet).